RSGallery2 support forums > RSGallery2 3.x bugs & problems

Converting from 1.5 to 1.6?

(1/2) > >>

YesSir:
Hi there,

I was wondering, is it possible to convert RSGallery2 form an existing Joomla 1.5 to a 1.6 site? I could not figure it out yet.

Thanks for your help!

YesSir:
Some extra info:

I tried with a 1.5 install and RSGallery2 2.2.0, which I upgraded to Joomla 1.6. After this I installed RSGallery2 3, but my galleries did not appear.

Replacing RSGallery2 with the latest version on Joomla 1.5 also did not work.

YesSir:
Solved it. For future reference, here is how I did it.

Starting with Joomla 1.5 & RSGallery2 2.2.0:

1. Use this guide: http://docs.joomla.org/Migrating_from_Joomla_1.5_to_Joomla_1.6
2. Install RSGallery 2 3 on your new 1.6 site
3. Rename the jos_rsgallery2 entries in the database to j16_rsgallery2
4. Copy the images/rsgallery2 from the 1.5 site to a folder in the 1.6 site

mirjam:
Thanks YesSir!

In addition:
The guide YesSir mentions uses jUpgrade. jUpgrade uses extension files to handle components, modules, etc. in the migration from J!1.5 to J!1.6. I'm looking into making such an extension.

jUpgrade converts your J!1.5 database tables to J!1.6 database tables in the same database where the new J!1.6 database tables have prefix "j16" (in default J!1.5 installation the prefix is "jos"). As far as I can tell from my first tests jUpgrade does not handle the rsgallery2 tables well (without extension file), therefore step 3 in YesSir's post is needed.

If you don't use jUpgrade you have to export the five #__rsgallery2_xxx tables (where #_ is your prefix and xxx stands for each of the five tables) from the J!1.5 installation and import them in the J!1.6 database, there are no changes in the tables. In addition to that you copy the /JOOMLA15ROOT/images/rsgallery/ folder (and its contents) from the J!1.5 installation to /JOOMLA16ROOT/images/rsgallery/ in the J!1.6 installation. Then install RSGallery2 3 (current version 3RC1).

Note: RSGallery2 v2.x is for Joomla 1.5.x and RSGallery2 v3.x if for Joomla 1.6.x.

YesSir:
Thanks for the extra info! I think I found one difference in the tables, a field called "alias" which I did not find in the older RSG2 version? I tried to add a picture and this error came up. A reinstall of RSG2 v.3 created this field (in the galleries and files table) and it is solved.

Navigation

[0] Message Index

[#] Next page

Go to full version