RSGallery2 Forum Portal

Language translations => General language and translation questions => Topic started by: Ixelink on September 16, 2011, 02:34:51 PM

Title: RsGallery 2.2.0 and Joomfish 2.1.7: can't install the XML files!
Post by: Ixelink on September 16, 2011, 02:34:51 PM
Hi All,

I've had a hard work to find it, but for the translate function of JoomFish I finally found the JoomFish2-contentelementfiles.zip, but it could not be installed; I got the error 'Joomla! can't find the XML-installation file".

What can be wrong? Is there another direct way to install them? Is it a wrong version?

Please help me out!

Greetings,

Maarten
Title: Re: RsGallery 2.2.0 and Joomfish 2.1.7: can't install the XML files!
Post by: Ixelink on September 16, 2011, 02:37:13 PM
BTW: the used Joomla! version is 1.5.23 Stable!
Title: Re: RsGallery 2.2.0 and Joomfish 2.1.7: can't install the XML files!
Post by: Ixelink on September 16, 2011, 09:11:43 PM
Hi there,

Can anyone tell me (perhaps also others?) what I can do with the .zip? Extract it and upload the files? I don't think so, because that would not install anything. But as I don't really know what exactly the XML files have to do, I can't figure out how to handle them. Installing the .zip didn't go via backend because of the error that an install file as missing.
What can I do then? Is there anyone out there that knows what to do? Please help me on this!

Regards,

Maarten

Title: Re: RsGallery 2.2.0 and Joomfish 2.1.7: can't install the XML files!
Post by: Ixelink on September 17, 2011, 01:13:50 AM
As nobody seems to react, I did some more Google research: looking a the XML files unzipped, they're not for Joomla 1.5, but for 1.0! I guess that this is the reason for the error, isn't it?
Does it mean that when 1.7 is already there, there is no JoomFish content element available for the translations in RsGallery2 after 1.0?

Regards,
Me again!

PS: No real Replies yet.
Title: Re: RsGallery 2.2.0 and Joomfish 2.1.7: can't install the XML files!
Post by: Ixelink on September 17, 2011, 05:30:57 PM
YES!

I suddenly thought that these XML files possibly should be used inside one of the JoomFish files (stupid of me not to realize it); the contentelements file! And uploaded it WORKS!!!!!!!

This post can be closed!

Title: Re: RsGallery 2.2.0 and Joomfish 2.1.7: can't install the XML files!
Post by: mirjam on September 19, 2011, 05:55:47 PM
For future reference (and a sticky topic will be created for this in the language section)
The downloads for RSGallery2 reside at joomlacode.org, see http://joomlacode.org/gf/project/rsgallery2/frs/ for a list (among which is the RSGalllery2 component itself).

In the list there is a RSGallery2_JoomFish entry that holds JoomFish content element files for JoomlFish 2.x on Joomla 1.5.x (and RSGallery2 2.x).

On the JoomFish website there are good instructions on how to translate 3rd party extensions (like RSGallery2), when they provide content element files:
http://www.joomfish.net/en/documentation/tutorials/213-translate-3rd-party-extensions

Basically these are the steps
- Make sure you have JoomFish 2.x (and RSGallery2 2.x) installed on your Joomla 1.5.x installation
- Make sure you have downloaded the content elements for RSGallery2: http://joomlacode.org/gf/project/rsgallery2/frs/?action=FrsReleaseBrowse&frs_package_id=5424
- Go to Backend > Components > Joom!Fish > Content Elements
- Click Install button at the top and select the downloaded zip file containing the content elements for RSGallery2
- Click Upload File & Install

For questions on how to translate your site and RSGallery2 items with JoomFish, please refer to the JoomFish website (http://www.joomfish.net). They have documentation, tutorial, a FAQ and if these don't help a forum for questions.

Does it mean that when 1.7 is already there, there is no JoomFish content element available for the translations in RsGallery2 after 1.0?
And to answer this question: currently there is no JoomFish for Joomla 1.6/1.7 yet, only for Joomla 1.5.x and these content element files you found.