RSGallery2 support forums > RSGallery2 2.x bugs & problems

you must provide a description

(1/1)

kasix:
i am using joomla 2.5 and the newst RSgallery

When i on the front end try to make a gallery i get the message "you must provide a description" and i have typed a description. it is only when i use joomlaCK editor  :-[

kasix:
my question is.
How do i fix it?
if it is not posible to fix, is there a way to make TinyCME the default editor only to the rsgallery part ?

mirjam:
Sorry for the late response (see signature...).

Perhaps this will work in 3.2.0:
Find the file /JOOMLAROOT/components/com_rsgallery2/lib/rsgcomments/rsgcomments.class.php. Find the function editComment on line 244 and scroll down to lines 295-320

--- Code: ---<?php 
//Get Joomla! configuration setting: is TinyMCE used as editor?
$app =& JFactory::getApplication();
if ( $app->getCfg('editor') == 'tinymce'){
// Get TinyMCE, but with limited number of buttons
?>
<script type="text/javascript">
tinyMCE.init({
mode : "textareas",
theme : "advanced",
width : "300",
theme_advanced_buttons1 : "bold,italic,underline,separator,link,unlink",
theme_advanced_buttons2 : "",
theme_advanced_buttons3 : "",
theme_advanced_toolbar_location : "top",
theme_advanced_toolbar_align : "left",
theme_advanced_statusbar_location : "none",
});
</script>
<textarea name="tcomment" id="tcomment" style="width:100%"></textarea>
<?php
} else {
// parameters : control name, content, width, height, cols, rows, show editor buttons, params
echo $editor->display('tcomment',  '' , '300px', '100px', '8', '20' ,false) ;
}
?>
--- End code ---
I had been playing there with the idea to automatically use TinyMCE, always. So to do that here you need to adjust the code a bit:

--- Code: --- <?php 
//Get Joomla! configuration setting: is TinyMCE used as editor?
$app =& JFactory::getApplication();
// if ( $app->getCfg('editor') == 'tinymce'){
// Get TinyMCE, but with limited number of buttons
?>
<script type="text/javascript">
tinyMCE.init({
mode : "textareas",
theme : "advanced",
width : "300",
theme_advanced_buttons1 : "bold,italic,underline,separator,link,unlink",
theme_advanced_buttons2 : "",
theme_advanced_buttons3 : "",
theme_advanced_toolbar_location : "top",
theme_advanced_toolbar_align : "left",
theme_advanced_statusbar_location : "none",
});
</script>
<textarea name="tcomment" id="tcomment" style="width:100%"></textarea>
<?php
// } else {
// parameters : control name, content, width, height, cols, rows, show editor buttons, params
// echo $editor->display('tcomment',  '' , '300px', '100px', '8', '20' ,false) ;
// }
?>
--- End code ---
(Four lines are commented with two slashes "//".)
By all means, this is no perfect solution, but it does allow you to not use your default editor. Perhaps there is a different way in Joomla of in your editor to do this, but I don't know your editor. Sorry.

Navigation

[0] Message Index

Go to full version