RSGallery2 Forum Portal

RSGallery2 support forums => RSGallery2 4.x bugs & problems => Topic started by: Malu on October 24, 2016, 10:16:07 AM

Title: File upload limit is 2MB
Post by: Malu on October 24, 2016, 10:16:07 AM
Hello,

Until yesterday it was no problem to upload an image that was larger than 2 MB.
The error message said that the limit was 2MB according to the ini.php.

I did not change anything, so how is it possible, that this restriction is suddenly there, I don't know.
Question: how can I change that restriction to e.g. 4,5 MB?

Many thanks in advance,

Hanneke Smulders
Title: Re: file upload limit is 2MB
Post by: whazzup on October 25, 2016, 02:32:30 PM
please check settings 
and
Maximum PHP file upload size is too small:
This is set in php.ini in both upload_max_filesize and post_max_size settings of your PHP settings (located in php.ini and/or .htaccess file)


Besides: The upload form tell in a red small line the size of one of above parameters
Title: Re: file upload limit is 2MB
Post by: Malu on October 27, 2016, 10:57:25 AM
The max size according to Media - component = 10 MB.

Sorry, I don't know where I can access the php.ini.
Maybe this is also possible after I installed the configuration repair template.
Title: Re: file upload limit is 2MB
Post by: whazzup on October 27, 2016, 12:33:46 PM
The settings in the php.ini may be accessible over your provider
Title: Re: file upload limit is 2MB
Post by: whazzup on July 31, 2017, 10:09:21 PM
Hello Malu,
i stumbled over a glitch. RSGallery2 did handle the size from php.ini partly wrong.
The sizes can be formated in php.ini with Mb, Kb Gb and others.
RSGallery2 used one (kB) format to determine the size and is wrong on the other formates.
This will be fixed in next version 4.3.2 within next months

if you need a fix before tell me and i send changed files

Regards whazzup