collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Can't get RSG "Show My Galleries" to work by Dampfnudel
[February 25, 2019, 11:01:55 AM]


Change the order of uploaded images in the gallery by whazzup
[February 19, 2019, 10:37:29 PM]


Upload timeout for large galleries (500 images each) by whazzup
[February 11, 2019, 10:07:25 PM]


Greetings from Ronald Smit by whazzup
[January 06, 2019, 03:39:22 PM]


Pluign and module by whazzup
[June 08, 2018, 11:57:13 PM]


Version 4.4.1 released by whazzup
[May 31, 2018, 04:31:16 PM]


search.html.php refer to rsgsearch.css with a wrong path by whazzup
[January 13, 2018, 08:12:04 PM]


Slow Gallery with many Photos by whazzup
[September 22, 2017, 09:22:33 AM]

Fixed: Joomla 3.5 install error

  • 2 replies
  • 3789 views
Fixed: Joomla 3.5 install error
« on: April 01, 2016, 02:58:04 PM »
Hello,
I have tried to install the rsgallery2 Version 4.1.0 in a fresh install of Joomla 3.5.  I am getting a error "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1' at line 3 SQL=CREATE TABLE IF NOT EXISTS `#__rsgallery2_dummy_is_eaten` ( `id` int(9) unsigned NOT NULL auto_increment, )ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ;"

I down graded the Joomla to 3.4.8 and it installed with no issues.

Any help would be appreciated.

Thanks
David
« Last Edit: April 07, 2016, 09:48:22 PM by whazzup »

Re: Joomla 3.5 install error
« Reply #1 on: April 03, 2016, 09:14:00 PM »
Sorry, the database part of
Quote
CREATE TABLE IF NOT EXISTS `#__rsgallery2_dummy_is_eaten` (
  `id` int(9) unsigned NOT NULL auto_increment,
)ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ;
has a comma after auto_increment which is wrong.

you may remove this comma and it will install correct.
Actually i test the sources for PHP7 and expect to create the next version on next weekend or shortly after
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

Fixed: Joomla 3.5 install error
« Reply #2 on: April 07, 2016, 09:47:05 PM »
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2