collapse

* User Info

 
 
Welcome, Guest. Please login or register.

* Recent Posts

Can't get RSG "Show My Galleries" to work by Dampfnudel
[February 25, 2019, 11:01:55 AM]


Change the order of uploaded images in the gallery by whazzup
[February 19, 2019, 10:37:29 PM]


Upload timeout for large galleries (500 images each) by whazzup
[February 11, 2019, 10:07:25 PM]


Greetings from Ronald Smit by whazzup
[January 06, 2019, 03:39:22 PM]


Pluign and module by whazzup
[June 08, 2018, 11:57:13 PM]


Version 4.4.1 released by whazzup
[May 31, 2018, 04:31:16 PM]


search.html.php refer to rsgsearch.css with a wrong path by whazzup
[January 13, 2018, 08:12:04 PM]


Slow Gallery with many Photos by whazzup
[September 22, 2017, 09:22:33 AM]

Installation problem

  • 5 replies
  • 4347 views
Installation problem
« on: March 08, 2015, 09:57:00 PM »
Hi,
Putting this in the forum after an earlier email exchange:
Problem:
I tried tot install the component (com_rsgallery2_4.0.4.J3x) on an upgraded (from 2.5) 3.3.6 installation, on a new 3.3.6 installation and on an updated 3.4 installation, but alas to no avail.
I am consistently getting the error:  ERR_EMPTY_RESPONSE', while in the server-log no php-errors or warnings are logged
PHP version is 5.5.20, MySQL 5.5.41. Later tried on a PHP 5.3.27 installation, same problem.

To answer your questions:
a) Do other component install example try akeeba
Yes , both Akeeba and other components install without problems

b) Can you have a look at the insides of the zip file. Does it look like a joomla intallation ?
I attached a screenshot of the contents in the temp folder of the server. They look the same as the contents of the .zip

c) If you unpack the files and put them to a folder on the server and try to start them there. Do you experience a different behaviour.
No, exactly the same results

d) does it happen with more than one browser
Yes, also tried Internet Explorer 11 and a different computer. IE simply states it cannot show the webpage

Re: Installation problem
« Reply #1 on: March 10, 2015, 09:04:23 PM »
Info from pwiert:
I did a last experiment: disabled all JLog statements in  install.rsgallery2.php.
The component then installs without errors. I can call the component and have created a  gallery
Will commence testing further tomorrow
Regards
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

Re: Installation problem
« Reply #2 on: March 10, 2015, 11:16:47 PM »
Hi,
Did some further testing today.
If I replace the log destination in line 29 of install.rsgallery2.php
that reads:
            'text_file_path' => 'logs'
with
            'text_file_path' => ''
the component installs just fine.
Can't get my head around why this is, because the webserver does have write permissions in the entire Joomla environment
Regards
Paul

Re: Installation problem
« Reply #3 on: March 11, 2015, 12:17:35 PM »
Hi everyone,
I had the same problem with pwiert and tried his solution, that is I replaced the log destination in line 29 of install.rsgallery2.php
that reads:
            'text_file_path' => 'logs'
with
            'text_file_path' => ''
and the component installed successfuly.

Well done pwiert and -of course- whazzup for your work!

Re: Installation problem
« Reply #4 on: March 11, 2015, 10:20:00 PM »
Thanks for your help.

The log was intended to go to administrator/log folder.

On my new installation yesterday (actual xampp with newest Joomla! 3.4)
i did check that the folder exists. I can slightly remember that i had
once to create that folder may be on upgraded joomla! but i am not sure.

Sorry that it backfires.
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

Re: Installation problem
« Reply #5 on: March 15, 2015, 11:11:58 PM »
I can confirm a standard installation doesn't have that folder. To keep things simple, I wouldn't have a problem with the logfile being written in the default Joomla log directory...
I also notices another problem on my site, but will create a separate post for that.