collapse

* User Info

 
 
Welcome, Guest. Please login or register.

* Recent Posts

Can't get RSG "Show My Galleries" to work by Dampfnudel
[February 25, 2019, 11:01:55 AM]


Change the order of uploaded images in the gallery by whazzup
[February 19, 2019, 10:37:29 PM]


Upload timeout for large galleries (500 images each) by whazzup
[February 11, 2019, 10:07:25 PM]


Greetings from Ronald Smit by whazzup
[January 06, 2019, 03:39:22 PM]


Pluign and module by whazzup
[June 08, 2018, 11:57:13 PM]


Version 4.4.1 released by whazzup
[May 31, 2018, 04:31:16 PM]


search.html.php refer to rsgsearch.css with a wrong path by whazzup
[January 13, 2018, 08:12:04 PM]


Slow Gallery with many Photos by whazzup
[September 22, 2017, 09:22:33 AM]

Fixed: White pages after installing Version 4.0.8.1

  • 18 replies
  • 11239 views
Fixed: White pages after installing Version 4.0.8.1
« on: June 10, 2015, 11:34:05 PM »
I downloaded the latest version of RSGallery2 intended for J3.X - the version 4.0.6 - and updating it issued just a few days ago - 4.0.8.1

Unfortunately , whether it's a new installation or after an upgrade from previous versions ( version with J2.5 ) , appears white page ( without error ) both on and administration

I've tested this on three different versions of Joomla ( J3.3 , J3.4.0 and J3.4.1 ) installed both on hosting how and localhost and everywhere the same, so that the rule (do not know whether rightly ) blamed the hosting or Joomla , besides, on J2.5 version works well.

Is there any way a diagnosis if there is only a white page ? hard to fix without error or statement
« Last Edit: June 19, 2015, 09:41:24 AM by whazzup »

Re: The problem with Joomla 3.x - white page
« Reply #1 on: June 11, 2015, 07:52:02 PM »
Sorry for the inconvienience, haven't heard about this before but i am not that long in error fixing here

Quote
Is there any way a diagnosis if there is only a white page ? hard to fix without error or statement

In firefox, internet explorer or chrome you may view the page contents as plain text. In firefox with right click on the page use something similar to "page source"

A far fetched hint. Which language do you use.  ? Maybe try to set it to english, just to see if it helps to use the situation we developers work.
Foreign translation may not be up to date.

You may present the results here or send them to me via PM. If you want i may look to your website. Send the details per PM
regards whazzzup
« Last Edit: June 11, 2015, 08:15:55 PM by whazzup »
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

Re: The problem with Joomla 3.x - white page
« Reply #2 on: June 14, 2015, 10:13:32 PM »
I have a request to check , I give this link

Please click on any image ,
website is under construction but it does not matter ( migrate from version J1.5.9 )

Thank you for your help
« Last Edit: June 20, 2015, 11:21:39 PM by intelauto123 »

*

Offline JtH

  • *
  • 4
Re: The problem with Joomla 3.x - white page
« Reply #3 on: June 15, 2015, 08:14:25 PM »
Hi,

it seems I have the same problem when installing to a fresh joomla 3.4.1 installation. After installing RSGallery I get a white page. I have put the error reporting on maximum and the following error appears:

Parse error: syntax error, unexpected '[' in ...\administrator\components\com_rsgallery2\includes\file.utils.php on line 603

I hope this can provide a direction to the problem.

Regards,
Jeroen

Re: The problem with Joomla 3.x - white page
« Reply #4 on: June 16, 2015, 06:29:31 PM »
That helps a lot.  I did trap into using a too new PHP function trying to create an array with "[]" which is supported on my development surrounding.
The quick fix is to change line 603 from
Quote
return [];
to
Quote
return;

i will create a new update as soon as it is possible for me. (maybe late this evening)
thanks for your patience
whazzup
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

*

Offline JtH

  • *
  • 4
Re: The problem with Joomla 3.x - white page
« Reply #5 on: June 16, 2015, 09:54:59 PM »
Thanks for the swift reply! I updated the code, but am getting a new error now:
..\administrator\components\com_rsgallery2\config.rsgallery2.php line 954.

Probably some additional lines.'

Cheers!


Re: The problem with Joomla 3.x - white page
« Reply #6 on: June 16, 2015, 10:23:59 PM »
All the same, i tried to search for it but failed.
The line should be

Quote
$fontlist = array();

too tired to do more today
Which PHP version is active ?
« Last Edit: June 16, 2015, 10:32:51 PM by whazzup »
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

Re: The problem with Joomla 3.x - white page
« Reply #7 on: June 16, 2015, 10:32:02 PM »
I checked the test installation of intelauto and see this behaviour.
White page after clicking on image. The resulting html is very short
Code: [Select]
<html><head></head><body></body></html>Hopefully with above changes it looks better
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

*

Offline JtH

  • *
  • 4
Re: The problem with Joomla 3.x - white page
« Reply #8 on: June 17, 2015, 08:42:54 PM »
My PHP version is:     5.3.13 at my home computer, at my hosting site it is 5.6

Re: The problem with Joomla 3.x - white page
« Reply #9 on: June 17, 2015, 09:34:22 PM »
Thank you for your interest in my problem

I fixed these two lines of php , but it did not help

I was looking for more bugs in the browser firefox , I found this :

" TypeError : invalid arguments adb.js : 296: 21
The character encoding of an HTML document has not been declared. When viewing this document in certain configurations browser , some characters outside the range of US -ASCII characters ( if any) may appear incorrectly. Character Encoding hand, it must be declared in the document or in the transmission protocol . index.php
TypeError : invalid arguments adb.js : 296: 21
TypeError : invalid arguments adb.js : 296: 21
TypeError : invalid arguments "

whether it might be helpful? or it may be related ?

Re: The problem with Joomla 3.x - white page
« Reply #10 on: June 17, 2015, 09:50:48 PM »
An update which fixes all known errors is ready http://www.rsgallery2.nl/index.php?topic=16951.0.
It runs on my site. Please try it out.
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

*

Offline JtH

  • *
  • 4
Re: The problem with Joomla 3.x - white page
« Reply #11 on: June 17, 2015, 10:14:34 PM »
works like a charm! Just tested it on a clean Joomla install and on the development environment of my website. Including the existing tables from my previous Joomla2.5 install.

Thanks so much!

Re: The problem with Joomla 3.x - white page
« Reply #12 on: June 17, 2015, 10:40:05 PM »
For me it has also helped

Thank you very much!

I cordially greet

Re: Fixed: White pages after installing Version 4.0.8.1
« Reply #13 on: June 23, 2015, 10:45:54 PM »
I have one request

I see the same problem ( white side ) on the module RSGallery2 Latest Images

Re: Fixed: White pages after installing Version 4.0.8.1
« Reply #14 on: June 24, 2015, 12:22:53 PM »
It would help if you have the debug in Joomla on so you can tell me the file and line but i will check it out anyhow
Which version of module RSGallery2 Latest Images are you using ?
« Last Edit: June 24, 2015, 12:29:53 PM by whazzup »
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2