collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Recent Posts

Can't get RSG "Show My Galleries" to work by Dampfnudel
[February 25, 2019, 11:01:55 AM]


Change the order of uploaded images in the gallery by whazzup
[February 19, 2019, 10:37:29 PM]


Upload timeout for large galleries (500 images each) by whazzup
[February 11, 2019, 10:07:25 PM]


Greetings from Ronald Smit by whazzup
[January 06, 2019, 03:39:22 PM]


Pluign and module by whazzup
[June 08, 2018, 11:57:13 PM]


Version 4.4.1 released by whazzup
[May 31, 2018, 04:31:16 PM]


search.html.php refer to rsgsearch.css with a wrong path by whazzup
[January 13, 2018, 08:12:04 PM]


Slow Gallery with many Photos by whazzup
[September 22, 2017, 09:22:33 AM]

Frontend upload link not showing, Did I miss something...

  • 9 replies
  • 4446 views
*

Offline LL8

  • *
  • 6
Frontend upload link not showing, Did I miss something...
« on: December 26, 2015, 08:44:47 AM »
So I want a public user to be able to upload pics....
And currently the way that ANY pic can be uploaded is only through the joomla admin site.
I'm not sure what I am doing wrong but there is no upload button anywhere...
Slideshow and downloads seem to be working fine.

I THINK i did the permissions correct.... but not sure where or why upload buttons/links are missing out...
any advice would be appreciated

NOTE: Im getting norton security to reevaluate site cause its giving out some error threat but yeah its safe -.-
http://lagunal8.net/bns/2015-12-26-01-25-28
but for the paranoid heres a gyazo image lol  :-[

Permissions from the gallery > edit gallery is as follows
https://gyazo.com/0d24024090b44d99c7d55c10c75c2912


Global config through Joomla is with these configurations:
https://gyazo.com/aa2abdea8f4798a8f354986ea2d417d3
« Last Edit: December 26, 2015, 11:02:40 PM by LL8 »

Re: Frontend upload link not showing, Did I miss something...
« Reply #1 on: December 26, 2015, 09:54:31 AM »
Dear LL8
A "public user" does mean a known logged in user or any user at all ?
Did you activate mygalleries in the configuration
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

*

Offline LL8

  • *
  • 6
Re: Frontend upload link not showing, Did I miss something...
« Reply #2 on: December 26, 2015, 11:11:44 AM »
it would mean any user at all, not just 'logged'

if by mygalleries, it is like this right now... if this is it
https://gyazo.com/2898f1c6b958e7b2ecaceb4de8712e51
« Last Edit: December 26, 2015, 11:02:08 PM by LL8 »

*

Offline LL8

  • *
  • 6
Re: Frontend upload link not showing, Did I miss something...
« Reply #3 on: December 27, 2015, 12:24:08 AM »
i tried looking at the debug mode:


rsgConfig Object
(
    [intro_text] =>
    [version] => 4.0.9
    [debug] => 1
    [allowedFileTypes] => jpg,jpeg,gif,png
    [hideRoot] =>
    [advancedSef] => 0
    [imgPath_thumb] => /images/rsgallery/thumb
    [imgPath_display] => /images/rsgallery/display
    [imgPath_original] => /images/rsgallery/original
    [imgPath_watermarked] => /images/rsgallery/watermarked
    [createImgDirs] =>
    [gallery_folders] =>
    [useIPTCinformation] => 0
    [uploadState] => 1
    [graphicsLib] => gd2
    [keepOriginalImage] => 1
    [jpegQuality] => 85
    [image_width] => 400
    [thumb_style] => 1
    [thumb_width] => 80
    [imageMagick_path] =>
    [netpbm_path] =>
    [ftp_path] =>
    [videoConverter_path] =>
    [videoConverter_param] => -i {input} -ar 22050 -ab 56 -b 200 -r 12 -f flv -s 320x240 -acodec mp3 -ac 1 {output}
    [videoConverter_thumbParam] =>  -i {input} -f mjpg -vframes 1 -an -s 320x240 {output}
    [videoConverter_extension] => flv
    [display_thumbs_style] => table
    [display_thumbs_floatDirection] => left
    [display_thumbs_colsPerPage] => 5
    [display_thumbs_maxPerPage] => 10
    [display_thumbs_showImgName] => 1
    [displayRandom] => 1
    [displayLatest] => 1
    [displayBranding] => 0
    [displayDesc] => 1
    [displayHits] => 1
    [displayVoting] => 1
    [displayComments] => 1
    [displayEXIF] => 0
    [displaySlideshow] => 1
    [displaySlideshowImageDisplay] => 1
    [displaySlideshowGalleryView] => 1
    [displaySearch] => 1
    [current_slideshow] => slideshow_parth
    [displayDownload] => 1
    [displayPopup] => 1
    [displayStatus] => 1
    [dispLimitbox] => 1
    [galcountNrs] => 10
    [template] => semantic
    [showGalleryOwner] => 0
    [showGallerySize] => 1
    [includeKids] => 1
    [showGalleryDate] => 0
    [exifTags] => FileName|FileDateTime|resolution
    [filter_order] => date
    [filter_order_Dir] => ASC
    [uu_enabled] => 0
    [uu_createCat] => 0
    [uu_maxCat] => 7
    [uu_maxImages] => 500
    [acl_enabled] => 0
    [show_mygalleries] => 1
    [show_mygalleries_onlyOwnItems] => 0
    [show_mygalleries_onlyOwnGalleries] => 0
    [watermark] => 0
    [watermark_type] => text
    [watermark_text] => (c) 2015 - RSGallery2
    [watermark_image] => watermark.png
    [watermark_angle] => 0
    [watermark_position] => 5
    [watermark_font_size] => 20
    [watermark_font] => arial.ttf
    [watermark_transparency] => 50
    [comment_security] => 1
    [comment_once] => 0
    [captcha_case_sensitive] => 0
    [captcha_image_height] => 60
    [captcha_perturbation] => 0.75
    [captcha_image_bg_color] => #0099CC
    [captcha_text_color] => #EAEAEA
    [captcha_line_color] => #0000CC
    [captcha_charset] => ABCDEFGHKLMNPRSTUVWYZabcdefghklmnprstuvwyz23456789
    [captcha_type] => 1
    [captcha_code_length] => 4
    [captcha_num_lines] => 2
    [voting_once] => 1
    [cookie_prefix] => rsgvoting_

Re: Frontend upload link not showing, Did I miss something...
« Reply #4 on: December 27, 2015, 03:40:30 PM »
i will look into it now. Sorry ACL and MyGalleries are sections i didn't touch too often.
* With your settings in the gallery view the "my galleries" link disappears as soon
as the last user is logged of.

It happens in file \templates\semantic\html\gallery.php at
Code: [Select]
//Show My Galleries link (if user is logged in (user id not 0))
if ($rsgConfig->get('show_mygalleries') AND (JFactory::getUser()->id)) {
   echo $this->showRsgHeader();
}

For a quick hack you may replace the "if" line with following and then the "MyGallery" link will show
Code: [Select]
if ($rsgConfig->get('show_mygalleries')) {
Next step is that i will check side effects. It looks like the programmers didn't expexct this need
« Last Edit: December 27, 2015, 06:20:48 PM by whazzup »
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

*

Offline LL8

  • *
  • 6
Re: Frontend upload link not showing, Did I miss something...
« Reply #5 on: December 28, 2015, 12:01:17 AM »
Thank you for getting back, rsgallery2 still is my priority gallery choice so I am hoping it can work out.

I will try this out as soon as i get home

*

Offline LL8

  • *
  • 6
Re: Frontend upload link not showing, Did I miss something...
« Reply #6 on: December 28, 2015, 07:25:08 PM »
Ive tried it out and this is what i get so far.

The My Gallery link successfully shows up on the initial page (capture.jpg)  :)
Under each category link,  the My Gallery is non existant (capture2.jpg) 

Is there a method that enable me to have public upload? This will be the most important so far as i want people who dont need to login to be able to upload pictures

thank you!

Re: Frontend upload link not showing, Did I miss something...
« Reply #7 on: December 29, 2015, 01:54:48 PM »
Trouble ahead :
On my test it shows images and galleries of user 0 when nobody was logged in. Furthermore
 two parts of the mygallery view were missing. So it is not as easy as expected.
Sadly i catched a cold so can't do anything in the next week
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

Re: Frontend upload link not showing, Did I miss something...
« Reply #8 on: December 29, 2015, 02:29:00 PM »
Sideeffects on open up storage for all possible users
Lets assume you got 100 "foreign" galleries with each 30 images.
Now everybody can upload and exchange every image. Even images with viruses, unallowed copies or otherwise unwelcome. (There is an industry for that)

It is easier to delete images of one user at once instead of scanning all images every day.
So my recommendation is to define a user type whose only ability is to handle images and give away new / auto created users to interested parties
« Last Edit: December 30, 2015, 09:09:02 AM by whazzup »
If you are looking for the newest version of  RSGallery2 for Joomla 3 please check out https://github.com/RSGallery2

*

Offline LL8

  • *
  • 6
Re: Frontend upload link not showing, Did I miss something...
« Reply #9 on: December 29, 2015, 10:20:01 PM »
understood, i will try that when i get home