collapse

* User Info

 
 
Welcome, Guest. Please login or register.

* Recent Posts

Can't get RSG "Show My Galleries" to work by Dampfnudel
[February 25, 2019, 11:01:55 AM]


Change the order of uploaded images in the gallery by whazzup
[February 19, 2019, 10:37:29 PM]


Upload timeout for large galleries (500 images each) by whazzup
[February 11, 2019, 10:07:25 PM]


Greetings from Ronald Smit by whazzup
[January 06, 2019, 03:39:22 PM]


Pluign and module by whazzup
[June 08, 2018, 11:57:13 PM]


Version 4.4.1 released by whazzup
[May 31, 2018, 04:31:16 PM]


search.html.php refer to rsgsearch.css with a wrong path by whazzup
[January 13, 2018, 08:12:04 PM]


Slow Gallery with many Photos by whazzup
[September 22, 2017, 09:22:33 AM]

Author Topic: Gallery display problem  (Read 39986 times)

Offline Jonathan

  • Retired from Dev Team
  • Jr. Member
  • ****
  • Posts: 70
Re: Gallery display problem
« Reply #45 on: September 08, 2007, 02:36:32 AM »
yes you can change the group of the file or the owner(do not suggest, just incase you want to upgrade), to a group that you apart of, or if you are comfortable with using VI, pico, or nano you can edit the document directly with sudo

Good Luck

Offline Maksin

  • Newbie
  • *
  • Posts: 12
  • Believe in Open Source
    • Believe in Open Source
Re: Gallery display problem
« Reply #46 on: December 20, 2007, 01:59:07 AM »
Same problem has happened to me.
Only I was getting the error for docman component and rsitems 1.4.2 alpha module, when using together.

Solution founded in file administrator/components/com_docman/contrib/pear/HTML_Select.php file.
Just delete 3 lines in file:
Code: [Select]
//only load if it hasn't already been loaded
if(!class_exists( "PEAR")) {
require_once dirname(__FILE__) . '/PEAR.php';
}

require_once dirname(__FILE__) . '/HTML_Common.php';


New code:
Code: [Select]
//only load if it hasn't already been loaded

require_once dirname(__FILE__) . '/HTML_Common.php';


It works, without a problems.
But it only works with rsgallery2_1.13.2-alpha.

With new version of gallery, even [SVN] the docman and rsitems 1.4.2 alpha module would not work at all.

Cheers  :)
Believe in Open Source. - www.maksin.ms

Offline Jonah

  • Retired from Dev Team
  • Hero Member
  • ****
  • Posts: 1.412
Re: Gallery display problem
« Reply #47 on: December 20, 2007, 10:05:35 PM »
Probably another namespace collision.  The 1.14 series contains the J15Backport project which will conflict with any other component that has backported classes from J1.5.  We have wrapped the most common collision classes with if class_exists but I'm sure there are many more.
Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.