collapse

* User Info

 
 
Welcome, Guest. Please login or register.

* Recent Posts

Can't get RSG "Show My Galleries" to work by Dampfnudel
[February 25, 2019, 11:01:55 AM]


Change the order of uploaded images in the gallery by whazzup
[February 19, 2019, 10:37:29 PM]


Upload timeout for large galleries (500 images each) by whazzup
[February 11, 2019, 10:07:25 PM]


Greetings from Ronald Smit by whazzup
[January 06, 2019, 03:39:22 PM]


Pluign and module by whazzup
[June 08, 2018, 11:57:13 PM]


Version 4.4.1 released by whazzup
[May 31, 2018, 04:31:16 PM]


search.html.php refer to rsgsearch.css with a wrong path by whazzup
[January 13, 2018, 08:12:04 PM]


Slow Gallery with many Photos by whazzup
[September 22, 2017, 09:22:33 AM]

Author Topic: [NOT A BUG] File size too large  (Read 2551 times)

Offline Tim

  • Newbie
  • *
  • Posts: 7
[NOT A BUG] File size too large
« on: December 12, 2007, 11:05:27 PM »
When trying to upload an image that is 2.01 meg I get an error saying the *Image size is too big for upload!* at the top of the page.  I realize there is a limit set for 2mb however I can put a php.ini file in the folder to change that.  In this I can say: upload_max_filesize = 5M and then 5meg would be the limit. 

My question is this, where would the PHP.INI file go?  Which folder do I need to place it in?  The file must be in the correct folder, as it doesn't apply to subfolders.  Rather than uploading it to every folder created I thought I'd ask which folder it should go in first.  I don't see a setting to change it in the component, so it should use this standard correct? Thanks!
« Last Edit: December 21, 2007, 07:36:24 AM by Ronald Smit »

Offline Jonah

  • Retired from Dev Team
  • Hero Member
  • ****
  • Posts: 1.412
Re: File size too large
« Reply #1 on: December 21, 2007, 12:23:04 AM »
The master php.ini file for your system is kept in a configuration directory.  Usually /etc/php or something similar on *nix OS.  You should ask your hosting provider to change this.
Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.

Offline Tim

  • Newbie
  • *
  • Posts: 7
Re: File size too large
« Reply #2 on: December 21, 2007, 02:27:06 AM »
The host has it set for 2 meg, and told us we could set it on our own by creating the php.ini file, however I'm not sure which folder it would go in for this gallery.  The ones I thought it would go in so far it hasn't worked.  He won't change the master file, it's up to us to add our own file.  I just need to know which folder it would go in.

Offline Jonah

  • Retired from Dev Team
  • Hero Member
  • ****
  • Posts: 1.412
Re: File size too large
« Reply #3 on: December 21, 2007, 05:02:58 AM »
It probably needs to be in the directory that the index.php you use is in.  So if you put it in both Joomla's root directory and the administrator directory that should work.
Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.

Offline Tim

  • Newbie
  • *
  • Posts: 7
Re: File size too large
« Reply #4 on: December 21, 2007, 05:16:03 AM »
I thought I tried that, and was going to reply that I had.  I figured I'd better check first, good thing I did.  It allowed me to upload an image over 2 meg!  I should have known to try that, but then again I'm no php pro LOL  Thanks!  Thats where it had to go.

Offline Jonah

  • Retired from Dev Team
  • Hero Member
  • ****
  • Posts: 1.412
Re: [NOT A BUG] File size too large
« Reply #5 on: December 21, 2007, 07:04:21 PM »
Glad it worked out.   :)
Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.